IAZ PRD -Subset of Customers Encountering Workflow Processing Delays

Incident Report for Ivanti Cloud

Resolved

Workflow processing seems to be stabilized for the customers that reported issues. Incident is resolved.
Posted Apr 13, 2026 - 16:15 UTC

Investigating

We are seeing delays in workflow processing on IAZ PRD for a subset of customers. We are investigating and will provide an update as soon as possible.
Posted Apr 13, 2026 - 14:52 UTC
This incident affected: Ivanti Neurons for IT Service Management & IT Asset Management (Service Manager / Asset Manager (IAZ)).