Ivanti Neurons Platform - Remote Control

Incident Report for Ivanti Cloud

Resolved

This incident has been resolved.
Posted 6 days ago. Apr 02, 2025 - 12:53 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted 6 days ago. Apr 02, 2025 - 07:29 UTC

Investigating

Impact
Remote Control to devices may fail to connect. Site Reliability Engineering is currently investigating the issue and will provide an update or notice of resolution once we have collected additional information.
Posted 6 days ago. Apr 02, 2025 - 05:51 UTC
This incident affected: Ivanti Neurons Platform (Ivanti Neurons Platform (MLU), Ivanti Neurons Platform (NVU), Ivanti Neurons Platform (UKU), Ivanti Neurons Platform (FRU), Ivanti Neurons Platform (TTU), Ivanti Neurons Platform (TKU)).