Ivanti Neurons Service Degradation

Incident Report for Ivanti Cloud

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 12, 2026 - 18:19 UTC

Investigating

Ivanti is investigating reports of slowness. Customer's may experience slowness during the log-in process and using the admin portal.

1918409
Posted Jun 12, 2026 - 17:01 UTC
This incident affects: Ivanti Neurons Platform (Ivanti Neurons Platform (NVU)).