Neurons for UEM - Device Discovery Delay – New Devices Not Visible in NVU - 1810488

Incident Report for Ivanti Cloud

Resolved

This incident has been resolved.
Posted Mar 17, 2026 - 13:21 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 17, 2026 - 08:46 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 17, 2026 - 00:54 UTC

Investigating

We are currently experiencing delays with device discovery in NVU. Newly installed agent devices or connector-imported devices may not appear as expected.
Posted Mar 16, 2026 - 22:47 UTC
This incident affected: Ivanti Neurons Platform (Ivanti Neurons Platform (NVU)).