Ivanti Neurons Platform - NVU - Device status changes (updates and deletes) may be delayed in the UI

Incident Report for Ivanti Cloud

Resolved

This incident has been resolved.
Posted Sep 26, 2025 - 07:03 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 25, 2025 - 12:02 UTC

Investigating

A subset of Neurons customers in the NVU environment may experience delays in device changes within the UI.

Site Reliability Engineering is currently investigating the issue and will provide an update or notice of resolution once we have collected additional information.
Posted Sep 24, 2025 - 19:33 UTC
This incident affected: Ivanti Neurons Platform (Ivanti Neurons Platform (NVU)).