Ivanti Neurons Platform (1664882) -- Device status changes (updates and deletes) may be delayed

Incident Report for Ivanti Cloud

Resolved

This incident has been resolved.
Posted Aug 28, 2025 - 13:50 UTC

Monitoring

Updates and deletes completing at expected rates.
Posted Aug 27, 2025 - 02:26 UTC

Identified

We have identified the cause of the current slowness. However, some tenants may still experience longer-than-usual delays when updating or deleting data.
Posted Aug 25, 2025 - 21:19 UTC

Investigating

We are currently investigating this issue.
Posted Aug 25, 2025 - 12:06 UTC
This incident affected: Ivanti Neurons Platform (Ivanti Neurons Platform (NVU)).