Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 21, 2025 - 06:30 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Oct 17, 2025 - 11:23 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Oct 14, 2025 - 19:15 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Oct 14, 2025 - 19:13 UTC
Scheduled
As part of our routine infrastructure improvements, we will be upgrading the environment for the NVZ CH STG Landscape. During this maintenance window, all tenant services will remain online and accessible. However, please be noted that users may experience brief latency or be logged out of active sessions.
Posted Oct 14, 2025 - 17:25 UTC
This scheduled maintenance affected: Ivanti Neurons for IT Service Management & IT Asset Management (Service Manager / Asset Manager (Ch-NVZ)).