Ivanti Neurons Platform - Tenants are unable to save credentials

Incident Report for Ivanti Cloud

Resolved

This incident has been resolved.
Posted Apr 04, 2026 - 01:34 UTC

Monitoring

We implemented a fix for this issue.
Posted Apr 04, 2026 - 01:31 UTC

Update

We are continuing to investigate this issue.
Posted Apr 04, 2026 - 00:36 UTC

Investigating

We are investigating an issue in Ivanti Neurons Platform FRU where tenants are unable to save credentials. The issue may also affect new connector creations and anything else that requires the credentials store.
Posted Apr 04, 2026 - 00:19 UTC
This incident affected: Ivanti Neurons Platform (Ivanti Neurons Platform (FRU)).