FFZ PRD- Email Service Degradation

Incident Report for Ivanti Cloud

Resolved

This incident has been resolved.
Posted Jun 26, 2026 - 08:47 UTC

Investigating

We are beginning to receive reports of emails for some of the tenants not processing on the FFZ PRD landscape. Our teams are currently investigating the impact and underlying cause of the issue. Further updates will be provided as more information becomes available.
Posted Jun 26, 2026 - 08:00 UTC
This incident affected: Ivanti Neurons for IT Service Management & IT Asset Management (Service Manager / Asset Manager (FFZ)).