Ivanti Neurons Platform - NVU - Deletes may be slow to complete - 1940141

Incident Report for Ivanti Cloud

Update

Deletes may still be slow to process. We are continuing to investigate and monitor the situation
Posted Jul 02, 2026 - 13:41 UTC

Monitoring

A fix has been implemented. Continuing to monitor as services catch up with backlogs.
Posted Jul 01, 2026 - 23:36 UTC

Investigating

A number of Neurons customers in the NVU environment may experience a degradation to the service, Deletes may be slow to complete.

Site Reliability Engineering is investigating the issue and will provide an update or notice of resolution once we have collected additional information.
Posted Jul 01, 2026 - 22:44 UTC
This incident affects: Ivanti Neurons Platform (Ivanti Neurons Platform (NVU)).