The emergency maintenance has completed, all services have been restored.
Posted Jul 17, 2026 - 13:21 UTC
Update
We are currently working on the activity and closely monitoring its progress. Once the activity is completed, we will provide you with an update.
Thank you
Posted Jul 17, 2026 - 12:59 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 17, 2026 - 12:00 UTC
Update
New Update: Please be advised that Ivanti will be performing emergency maintenance on the Ivanti Neurons for ITSM environment. This activity includes scaling up platform resources, increasing service capacity, and optimizing system performance to help ensure continued platform stability, reliability, and the best possible customer experience. We apologize for the short notice and appreciate your understanding and patience while this important work is completed. We will continue to monitor the environment closely throughout the maintenance activity.
Ivanti will be performing emergency maintenance on the landscape below: NSZ PRD
Maintenance Window: Start Date/Time: July 17, 2026, 12:00 UTC End Date/Time: July 17, 2026, 14:00 UTC
Impact: During the maintenance window, tenant environments will remain online and available. However, users may experience minor latency, brief service interruptions, or may be logged out of their current session during the deployment activities.