Ivanti Neurons Platform - NVU - Device status changes (updates and deletes) may be delayed in the UI

Incident Report for Ivanti Cloud

Identified

Site Reliability Engineering has identified the problem and will be applying a fix
Posted Sep 26, 2025 - 21:15 UTC

Investigating

Site Reliability Engineers are investigating the delay
Posted Sep 26, 2025 - 19:00 UTC
This incident affects: Ivanti Neurons Platform (Ivanti Neurons Platform (NVU)).