Ivanti Neurons for Secure Access and Zero Trust Access - Americas - Degraded

Incident Report for Ivanti Cloud

Resolved

This incident has been resolved.
Posted Apr 24, 2026 - 19:50 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 24, 2026 - 16:26 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 24, 2026 - 15:56 UTC

Update

Currently Neurons for Secure Access in North America region is experiencing a degradation. Ivanti is Aware of this and working on solution. We will further update shortly.
Posted Apr 24, 2026 - 15:37 UTC

Investigating

We are currently investigating this issue.
Posted Apr 24, 2026 - 15:20 UTC
This incident affected: Ivanti Neurons for Secure Access and Zero Trust Access (AMERICAS).