Neurons for UEM - Audit trails not available in NVU - 1814445

Incident Report for Ivanti Cloud

Resolved

This incident has been resolved.
Posted Mar 23, 2026 - 15:52 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 20, 2026 - 22:08 UTC

Investigating

We are currently investigating an issue with the Neurons product affecting all customers on the NVU landscape. Audit Trails are not updating, and new activity is not visible at this time.
Posted Mar 20, 2026 - 18:55 UTC
This incident affected: Ivanti Neurons Platform (Ivanti Neurons Platform (NVU)).