NVZ Prod - Performance Degradation - delays with Escalation Queue Processing

Incident Report for Ivanti Cloud

Resolved

This incident has been resolved.
Posted Apr 28, 2026 - 22:06 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 28, 2026 - 20:39 UTC

Update

We continue to see delays with Escalation Queue Processing and are actively investigating. We will continue to provide updates here.
Posted Apr 28, 2026 - 20:04 UTC

Update

We continue to see delays with Escalation Queue Processing and are actively investigating. We will continue to provide updates here.
Posted Apr 28, 2026 - 19:02 UTC

Update

We continue to see delays with Escalation Queue Processing and are actively investigating. We will continue to provide updates here.
Posted Apr 28, 2026 - 18:01 UTC

Investigating

We are currently aware of an issue causing slower performance for escalations within the NVZ PRD landscape. Our technical team is actively investigating and working to resolve this as quickly as possible.

We apologize for any inconvenience this may cause and appreciate your patience while we work to restore normal service. We will keep you updated as soon as we have more information.

If you have any immediate concerns or require assistance, please do not hesitate to reach out to our support team.
Posted Apr 28, 2026 - 16:59 UTC
This incident affected: Ivanti Neurons for IT Service Management & IT Asset Management (Service Manager / Asset Manager (NVZ)).